メディア・アイキャッチ共に画像を挿入できない状態です。

現在記事に画像を挿入できない現象が起こっています。

アイキャッチの設定も画像が読み込まれません。

ボタンはクリックできますが、画面が開いてからの画像の読み込みがされないのです。

何を触ったかと言われると、何も触っていないのですが、ワードプレス自体をバージョンアップしました。

それ以外に触っていないので原因は・・・。

物件の画像を挿入しようとした矢先だったので、完全にやる気を失っております。

当然ググってみた

「ワードプレス、画像挿入できない」でググってみますと、古い記事で似たような症状と、原因と解決策がそれなりにでてきました。
原因については
  1. WordPressのアップデート
  2. プラグインの追加
  3. プラグインのアップデート
  4. javascriptの無効化

この4点が主に原因であるようです。

私の場合は1と4が該当しそうです。


そしてどの記事にも、大きく3つの解決方法が示されています。
  1. プラグインの干渉による原因の為、プラグインを1つずつ確認
  2. phpを訂正・追加
  3. バージョンダウン

この3点がほとんどの記事で書かれています。

真っ先にプラグインもを全て停止し試してみましたが、違いました。

バージョンダウンは簡単そうに書いているのですが、素人には敷居が高そうなのでパスしました。

しかしワードプレスのバージョンアップが原因ならば、バージョンダウンが正しい処方箋の様な気もします。

次のバージョンアップ時にどうなのか分からないのもあるので、やはりパスです。

phpについては、最新のものに関しての記事ではないので、相違点があるので、こちらも素人には難しいのでパスしました。

結局解決できない・・・。
失敗

偶然の成功と方法

根本的な解決は出来ていないですが、全くの偶然で応急処置の方法は見つけましたので、同じ症状で、php等を触りたくない方は試してみて下さい。

私はGoogleをブラウザで使用しています。

投稿ページでGoogleのディベロッパーツールを使用することで、再読み込みがされ、なぜだか画像の挿入が出来ました。

これなら簡単ですね。

右クリックして検証をクリックするだけです。

要は何等かの原因で、画像を読み込んでいないだけなのでしょう。

しかし素人にはそんなもんわかりません。

教えて頂ける方やサイトがありましたら、ご教授ください。

面倒くさいが画像は張り付けれる

私の場合、普通にメディアは開きます。

画像も表示されます。

なので記事内には、画像のURLを使用して貼り付けることは可能です。

が、クリック1つで出来ていたことからすると面倒くさいです。

大した作業では無いのですが、気分的なものですね。
画像のURL” alt=”” width=”268″ height=”188″ class=”alignnone size-full wp-image-975″ />

メディアを開いてURLをコピー。1手間増えただけです。

なんてものぐさなんだ・・・。



当面はどちらかの方法で誤魔化していきます。

根本的な解決法で、簡単なものがあれば、また報告しますね。

解決しました

私が解決した方法は?

シークレットモードで起動すると表示は完璧でした。

そして試行錯誤の末、拡張機能の一つが犯人であることが判明しました。

「Googleクロム 表示がおかしい」で検索をかけると、Googleのアンインストールと再インストール、クッキーや閲覧履歴の削除といった方法がたくさん出てきますが、フォントや表示がおかしい場合は拡張機能が犯人の場合があるようです。

DirectWriteなるものを有効にするという方法もありましたが、chrome://flags/で画面を開いても現在はDirectWriteの項目がありませんでした。

  1. シークレットモードで表示の確認

  2. 問題なければキャッシュや閲覧履歴のクリア

  3. クロムのアンインストールと再インストール

  4. 拡張機能の確認

という順番で確認作業してみて下さい。

3・4は順番はどちらでも大丈夫でしょう。

私が解決した方法でした。